Pré-requis

L'extension OCI8 nécessite les bibliothèques clientes 9iR2, 10g, 11g ou 12c. Si la base de données Oracle est sur la même machine que PHP, le logiciel de la base de données contient déjà toutes les bibliothèques nécessaires. Lorsque PHP est sur une machine différente, vous devez utilisez les bibliothèques libres » Oracle Instant Client.

Pour utiliser Oracle Instant Client, installez le fichier compressé basic ou basiclite de Oracle Instant Client ou le paquet RPM. Lorsque vous compilez PHP depuis ces sources, installez également le fichier compressé sdk ou le paquet RPM devel.

Sous Windows, la bibliothèque DLL php_oci8 requiert les bibliothèques clientes depuis la version 10gR2 ou supérieure. En PHP 5.3, incluant PHP 5.3.5, la bibliothèque DLL php_oci8_11g requiert les bibliothèques clientes Oracle 11gR1 ou supérieur. A partir de PHP 5.3.6, la bibliothèque DLL php_oci8_11g requiert les bibliothèques clientes Oracle 11gR2 ou supérieur. Suivant la version du client Instant, vous pourriez également avoir besoin des bibliothèques mfc71.dll et msvcr71.dll.

Vous devriez exécuter PHP avec la même version (ou plus récente) des bibliothèques Oracle utilisées pour compiler OCI8.

Note:

Si OCI8 utilise les bibliothèques clientes 9iR2 ou 10g, alors PHP peut se connecter aux bases de données Oracle 8i, 9iR2, 10g, 11g ou 12c. Si OCI8 utilise les bibliothèques clientes 12c, la base de données peut être 10gR2, 11g ou 12c.

Note:

Le support de toutes les fonctionnalités OCI8 n'est disponible que lors de l'utilisation des versions les plus récentes des bibliothèques clientes mais aussi de la base de données la plus récente.

add a note add a note

User Contributed Notes

There are no user contributed notes for this page.
To Top