Last 5.3 release ever available: PHP 5.3.29 - 5.3 now EOL

Schimbări incompatibile în sens invers

Cu toate că majoritatea codului-sursă existent în PHP 4 ar trebui să funcționeze fără schimbări, totuși ar trebui să atrageți atenția la următoarele schimbări incompatibile în sens invers:

  • Sunt unele noi cuvinte-cheie rezervate.
  • strrpos() și strripos() acum utilizează întregul string în calitate de 'ac'.
  • Utilizarea nelegală a deplasamentelor în string-uri cauzează E_ERROR în loc de E_WARNING. Un exemplu de utilizare nelegală ar fi: $str = 'abc'; unset($str[0]);.
  • array_merge() a fost schimbată pentru ca să accepte numai tablouri. Dacă îi este transmisă o variabilă care nu este tablou, un E_WARNING va fi aruncat pentru fiecare astfel de parametru. Fiți atent, deoarece codul dumneavoastră poate să înceapă să emită E_WARNING din senin.
  • Variabila de server PATH_TRANSLATED nu mai este stabilită implicit sub Apache2 SAPI în contrast cu situația în PHP 4, unde ea este stabilită la aceeași valoare ca și variabila de server SCRIPT_FILENAME, atunci când nu este populată de Apache. Această schimbare a fost făcută pentru a ne conforma cu » specificația CGI/1.1. Vă rugăm să vă referiți la » bug #23610 pentru informații suplimentare și vedeți de asemenea descrierea $_SERVER['PATH_TRANSLATED'] în manual. Această problemă de asemenea afectează versiunile PHP >= 4.3.2.
  • Constanta T_ML_COMMENT nu mai este definită de către extensia Tokenizer. Dacă error_reporting este stabilită la E_ALL, PHP va genera o notificare. Cu toate că T_ML_COMMENT niciodată nu a fost utilizată, ea a fost definită în PHP 4. În ambele PHP 4 și PHP 5 // și /* */ sunt soluționate ca constante T_COMMENT. Însă comentariile în stil PHPDoc /** */, care începând cu PHP 5 sunt înțelese de PHP, sunt recunoscute ca T_DOC_COMMENT.
  • $_SERVER ar trebui să fie populată cu argc și argv dacă variables_order include "S". Dacă ați configurat sistemul dumneavoastră în mod specific să nu creeze $_SERVER, atunci desigur ea nu va fi. Schimbarea a fost de a face argc și argv disponibile în versiunea CLI indiferent de setarea variables_order. Deci versiunea CLI acum întotdeauna va popula variabilele globale $argc și $argv.
  • Un obiect fără proprietăți nu mai este considerat "vid".
  • În unele cazuri clasele trebuiesc declarate înainte de a fi utilizate. Aceasta se întâmplă numai dacă unele facilități noi ale PHP 5 (cum ar fi interfețele) sunt utilizate. În caz contrar, comportamentul este pe vechi.
  • get_class(), get_parent_class() și get_class_methods() acum întorc numele claselor/metodelor așa cum ele au fost declarate (respectându-se literele majuscule/minuscule), ceea ce poate duce la probleme cu script-urile mai vechi care se bazează pe comportamentul vechi (numele claselor/metodelor întotdeauna erau întoarse cu litere minuscule). O soluție posibilă este de a căuta aceste funcții în toate script-urile și de a le aplica strtolower(). Această diferențiere a literelor majuscule/minuscule de asemenea se aplică la constantele predefinite magice __CLASS__, __METHOD__ și __FUNCTION__. Valorile sunt întoarse exact cum sunt declarate (respectându-se literele majuscule/minuscule).
  • ip2long() acum întoarce FALSE când o adresă IP nevalidă îi este transmisă ca argument și nu -1 ca înainte.
  • Dacă există funcții definite într-un fișier inclus, ele pot fi utilizate în fișierul de bază indiferent dacă se află înainte de return sau după. Dacă fișierul este inclus de două ori, PHP 5 va emite o eroare fatală deoarece funcțiile au fost declarate deja, în timp ce PHP 4 nu se plânge de acest fapt. Este recomandat de a utiliza include_once în loc de a verifica dacă fișierul a fost inclus deja și de a ieși în acest caz din fișierul inclus.
  • include_once și require_once întâi normalizează calea fișierului inclus în Windows astfel încât includerea A.php și a.php va include fișierul numai o singură dată.
  • Transmiterea unui masiv prin valoare unei funcții nu mai resetează indicatorul intern al tabloului pentru accesele la tablou prin intermediul acestei funcții. Cu alte cuvinte, în PHP 4 când transmiteați un tablou unei funcții, indicatorul intern al tabloului era resetat, în timp ce în PHP 5, când transmiteți un tablou unei funcții, indicatorul tabloului în interiorul funcției rîmâne acolo unde era la momentul când tabloul a fost transmis funcției.

Example #1 strrpos() și strripos() acum utilizează întregul string în calitate de 'ac'

<?php
var_dump
(strrpos('ABCDEF','DEF')); //int(3)

var_dump(strrpos('ABCDEF','DAF')); //bool(false)
?>

Example #2 Un obiect fără proprietăți nu mai este considerat "vid"

<?php
class test { }
$t = new test();

var_dump(empty($t)); // echo bool(false)

if ($t) {
    
// Va fi executat
}
?>

Example #3 În unele cazuri clasele trebuie declarate înainte de a fi utilizate

<?php

// funcționează fără erori:
$a = new a();
class 
{
}


// aruncă o eroare:
$a = new b();

interface 
c{
}
class 
implements {
}

?>

add a note add a note

User Contributed Notes 13 notes

up
1
paul at oconnor-web dot net
6 years ago
The __call function will also lowercase the method arguement:

<?php
  
function __call($method, $args) {
     if (
$method == 'Foo') {
       return
true;
     } else {
       return
false
    
}
   }
?>

(= false)
up
1
nami
7 years ago
addition of the note on 07-Sep-2004 06:40

if you write down your code like this PHP5 will just work fine:

<?php
     $array_1
= array('key1'=>'oranges','key2'=>'apples');
    
$array_2 = array('key3'=>'pears','key4'=>'tomatoes');
    
$array_3 = array();
    
$arr_gemerged = array_merge($array_1,$array_2,$array_3);
     echo
"result:<br>";
    
print_r($arr_gemerged);
     echo
"<br>";
?>

---

so you have to declare array_3 as array() instead of NULL
up
2
michael dot darmousseh at gmail dot com
4 years ago
Hack way to fix the array_merge problem so that it works with your existing php4 code

<?php
function array_merge5()
{
   
$args = func_get_args();
    foreach(
$args as $key=>$arg)
       
$args[$key] = (array) $arg;
    return
call_user_func_array("array_merge", $args);
}
?>

just put it somewhere completely accessible to your codebase and change all of your calls to array_merge to array_merge5.
up
2
john.g
9 years ago
PATH_TRANSLATED is handy when using Apache's ModRewrite engine, as it gives you the name and path of the resulting file rather than the one that was requested by the user. Since PHP 5.0 and Apache 2 no longer support this variable, I created a workaround by adding an environment variable to my ModRewrite command:

Original:
RewriteRule ^/test/(.*)\.php(.*) /test/prefix_$1.php$2

Adjusted:
RewriteRule ^/test/(.*)\.php(.*) /test/prefix_$1.php$2 [E=TARGET:prefix_$1.php]

I could then find out the resulting file name through the super global $_ENV, for instance:

<?php
echo "The actual filename is ".$_ENV['REDIRECT_TARGET'];
?>

Note: The "REDIRECT_" prefix appears to be allocated automatically by ModRewrite.
up
1
Aggelos Orfanakos
6 years ago
As with array_merge(), array_merge_recursive() returns NULL in PHP 5 if a non-array parameter is passed to it.
up
1
Anonymous
8 years ago
is_a have been deprecated. You can simply replace all occurences with the new instanceOf operator, although this will break backwards-compatibility with php4.
up
0
kemal djakman
7 years ago
The handling of accessing empty property of a class error has also changed:
<?php

class Foo {

    var
$Bar = 'xxx';

    function
F() {
        echo
$this->$Bar;
    }
}

$Obj = new Foo();
$Obj->F();

?>

Notice the $ sign after object dereference opr?  $Bar is empty inside method F.   PHP4 would only generate a warning, PHP5 throws a fatal error
up
0
Amir Laher
7 years ago
Some other things to be aware of:

some extra strictness:
* object members can no longer be accessed using array-member syntax
* function-calls with too many arguments will now cause errors.

Also, from PHP5.2, custom session handlers are affected:
* Best not to use global objects in custom session-handling functions. These would get destructed *before* the session is written (unless session_write_close() is called explicitly).
up
0
dward . maidencreek.com
9 years ago
Another change that we've had problems with while trying to use PHP4 code in PHP5 is how $this is carried across static method calls if they are not declared static in PHP5.  The main issue was that debug_backtrace() now shows the first class with -> instead of the second with :: in the backtrace element when the method in the second class was called statically (using ::) from a method in the first class.
up
0
cyberhorse
10 years ago
clone() is a php function now.

if you create a subclass, it no longer uses samename methods in superclass as a constructor.
up
-1
Steven
6 years ago
Three more that we discovered:

== 1. No longer can re-assign $this ==

The follwoing example works under PHP4 (it outputs "OK"), but produces a fatal error under PHP5:

<?php
 
class a
 
{
    var
$text;
    function
a() { $this->text = 'OK'; }
  }

  class
b
 
{
    var
$text = 'NOT OK';
    function
b() { $this = new a(); }
  }
   
 
$myClass = new b();
  echo
$myClass->text;
?>

== 2. No comments allowed after shorthand echo block ==

The follwoing example works under PHP4, but produces a sytax error under PHP5.

<?=//comment?>

== 3. Constructors return a reference as default ==

The follwoing example works under PHP4, but produces an E_NOTICE notice under PHP5.

<?php
 
class MyClass { function MyClass() { echo('OK'); } }
 
$myObj = null;
 
$myObj &= new MyClass();
?>

Removing the ampersand solves the problem
up
-1
Anonymous
9 years ago
Be careful with array_merge in PHP5.1 not only a E_WARNING is thrown, but also the result is an empty array. So if you merge two select queries and the last one is empty you will end up with no array at all.

<?php
        $array_1
= array('key1'=>'oranges','key2'=>'apples');
       
$array_2 = array('key3'=>'pears','key4'=>'tomatoes');
       
$array_3 = null;
       
$arr_gemerged = array_merge($array_1,$array_2,$array_3);
       
print_r($arr_gemerged);
        echo
"<br>";
?>

Result on php4:
Array ( [key1] => oranges [key2] => apples [key3] => pears [key4] => tomatoes )

Result on php5:
Warning: array_merge() [function.array-merge]: Argument #3 is not an array in /removed/by/danbrown/for/manual.php on line 7
up
-1
Sinured
7 years ago
Not mentioned above: The PHP/FI 2 function style (old_function aka cfunction) is no longer supported as of PHP 5.
To Top